Old versions

The newest version of PeakFinder uses the OpenGL-library. Unfortunately on some Android devices this does not work correctly yet. I'm trying to fix this as quickly as possible. Until then you can install the old version of PeakFinder (2.7.0 April 2016). Delete first the installed version. Then open the following link directly on your device.

Google Play:
http://updates.peakfinder.org/downloads/android/PeakFinderEarth270.apk
Amazon:
http://updates.peakfinder.org/downloads/android/PeakFinderEarthAmazon270.apk